








12. Customize Hot Keys & User Interface
3D-Coat is fully customizable, and it is quick and easy to do. All 
UI settings, hotkeys and other customized information are stored 
in a small XML file, allowing for easy distribution of all custom-
ized presets. 

12.1 Customize Hotkeys
To define a hotkey is very simple. All you need to do is point your 
cursor over the item you would like to set a hotkey for and press 
the END key – you will then see this prompt: 

You can now press the key(s) you would like to assign to the func-
tion. Keep in mind that nearly every button or menu item you see 
in 3D-Coat already have a custom hotkey. If a hotkey is already 
used, it is no problem to re-assign the hotkey to whatever new 
hotkey you would like.

12.2 Customize 
User Interface
The UI layout of 3D-Coat is fully 
customizable. By default there 
are three UI themes included 
in the installation. They are 

“Dark”, “Grey” and “Light”. 
You can change this by going 

to Edit–>Preferences–>Load, and you will then be directed to a 
folder named “OptionsPresets. There are 3 .xml files in it, and each 
of them is corresponds to an interface theme. To load the themes, 
simply select one .xml file and click Open. You can of course edit 
many more parts of the UI and create your own UI theme and 
save it as an .xml file. Just go to Edit->Preferences. Here you can 
customize the color of text, interface background, header, but-
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tons, grid, background, and so 
on. You can also turn on/off 3D 
button style, Gradient menus.

After all these done, just 
save the .xml file, and all the 
new customized information 
are stored. You can load it any-
time on your own systems or 

share it with your friends and colleagues. Simply press the but-
ton Save in the Preferences panel. 

You can even change the icons of the tools to your own, just 
go to the installation folder of 3D-Coat. In the subfolder path 
textures\icons you will find the source .psd files of the icons, they 

are Baseicons.psd and Smal-
lIcons.psd, open the .psd file 
in Photoshop and create your 
own icons. When finished, save 
them in the .dds format, keep 
the name and replace the origi-
nal Baseicons.dds and Smal-
lIcons.dds. The next time you 
start 3D-Coat it will load all the 
new custom icons.
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13. CUDA
13.1 CUDA Basics
3D-Coat uses CUDA acceleration for voxel sculpting only. Voxel 
sculpting requires more computing resources because it handles 
pictures in volume. So we decided to use CUDA to speed up 
volume operations. CUDA is supported by all the recent NVidia 
cards, starting with the 8-series. 

However the acceleration is hugely dependent on the num-
ber of processors available on the card. The real advantage of 
CUDA over a 4-core CPU can be achieved only if the GPU has more 
then 64 processors, otherwise the 4-Core CPU alone will yield 
a better speed. So there is no reason to use CUDA acceleration 
with some video cards, even though they support the technol-

ogy – like the GeForce 8400/9400, 8500/9500, G100, G120, G130 
and QuadroFX 1700 – because they have less than 64 processors. 

We can recommend any card from GeForce 9800GT (it’s very 
inexpensive) and higher. Acceleration speed is dependent not 
only the number of cores number but also on memory bandwidth. 

CUDA gives the best speed advantage if you are applying 
masks and materials over voxel sculpture with big brushes. The 
speed advantage depends considerably on the tool used. 

13.2 The Benchmark
Here is the benchmarking info for a standard PC with a 4-core 
CPU (Q6600, 2.4 GHz, GPU 9800GT). We ran 6 tests, using several 
types of drawing with a mask either enabled or disabled. 

Draw with sphere: CUDA+thin pen(10) Avg. FPS:31.3
Draw with sphere: CPU+thin pen(10) Avg. FPS:30.5
Carve: CUDA+thin pen(10) Avg. FPS:34.1
Carve: CPU+thin pen(10) Avg. FPS:30.5
Carve with mask: CUDA+thin pen(10) Avg. FPS:31.0
Carve with mask: CPU+thin pen(10) Avg. FPS:26.4
Draw with sphere: CUDA+thick pen(40) Avg. FPS:13.6
Draw with sphere: CPU+thick pen(40) Avg. FPS:10.4
Carve: CUDA+thick pen(40) Avg. FPS:18.3
Carve: CPU+thick pen(40) Avg. FPS:10.3
Carve with mask: CUDA+thick pen(40) Avg. FPS:14.3
Carve with mask: CPU+thick pen(40) Avg. FPS:7.2
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The largest advantage of CUDA over CPU-only is visible when 
a mask is used. The faster FPS numbers means, of course, more 
speed. 9800GT is a very low-priced card, but using a GTX260 or 
later or a QuadroFX with a large amount of cores will give the 
best speed. 

It is cheaper to buy a good video card than, for example, a 
Core i7 processor. 

We can also recommend buying a video card with 1GB or 
more of memory, because it will allow you to edit really large 
textures in 3D-Coat. 

CUDA’s efficiency is limited on very large brushes, so, when 
reaching a particular radius, CUDA will be automatically disabled 
in tools like the Airbrush, Increase, Build and Smudge. On a scale 
of 1:1 it is a radius of around 65. The surface and object tools are 
not getting any advantage from CUDA.
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14. FAQ/Additional Tips 
14.1 For Your Information!
Sometimes my painting operations become very slow. How 
can I best avoid it?

•	Painting over large single faces will be much slower then 
over divided faces. So try to avoid too big faces in UV-space. 
Divide large faces whenever possible.

I am getting the error message “The application failed to start 
because d3dx9_38.dll was not found”. What should I do?

•	Go to our Download page, look for the DirectX 9c download 
and install it. Even if you have DirectX 10 installed you need 
to update DirectX 9. DirectX 9 and 10 are independent, so 
this procedure is quite safe. 

I want to upgrade my video card to speed up 3D-Coat. What 
should I choose?

•	Using modern nVidia cards is best, due to CUDA. You can 
choose from NV 8800GT (lowest price) to GTX 285 and higher. 
There is no reason to use multiple GPU cards (SLI) for 3D-Coat. 
The most important factor for CUDA performance is the num-
ber of cores – it should be 120 or more. Video RAM is impor-
tant also, because it determines the maximum texture size 
that can be edited in 3D-Coat. Every pixel takes 8 bytes, so 
you can easily calculate the maximum size of the texture that 
can fit into the GPU’s memory. We recommend you buy cards 
with at least 1 Gb of RAM, even more is even better. 

Do I need to uninstall 3D-Coat every time I install your new 
software upgrades?

•	No, you can install the update simply by overwriting the 
existing installation (at least until we release a major, non-
free version upgrade).

I am unable to register – every time I enter serial number 
and press Register, 3D-Coat restarts and asks for the serial 
number again. How can I exit this loop? 

•	Check if you might have copied to the clipboard extra char-
acters – or missed some characters 

•	Check that the serial number is for 3D-Coat Version 3 – often 
users are entering serial numbers for Version 2. Version 3 
serial number begins with 3DC3SN-.

•	If you are under Vista x64, please ensure that you are running 
3D-Coat as an administrator. 

•	If the problem still persists try to delete the file License.dat 
from the 3D-Coat installation folder manually. 

There are too many texts hints in the interface, is there a way 
to hide them?

•	If you are new to 3D-Coat, 
it isn’t recommended that 
you hide the hints, because 
these will really be helpful 
for your study. But you can 
hide the hints anytime you 
want, just go to the menu 
Edit->Preferences->Show 
hints and uncheck that 
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checkbox. You can turn on or off the big bottom hints sepa-
rately by using “Show big hints on the bottom panel”.

I am using Vista/XP 64-bit and 3D-Coat does not respect my 
Wacom pen pressure. What should I do?

•	3D-Coat works well with 64-bit drivers. Get the latest Wacom 
driver here: www.wacom.com/downloads/drivers.php

Can I move/rotate/scale the objects but not the camera?

•	Yes, you can. In the “Sculpt mode” of tools panel, select the 
“Select/Move” command – then you can select the object 
you want to move/rotate/scale.

How can I adjust the pivot point?

•	In 3D-Coat, the pivot point is dynamic and based on the 
currently picked point (where you cursor last pointed on the 
model). But you can set the pivot point manually using the 

“F” key. Also, please see the Camera menu – it lets you pick 
the best pivot mode.

What’s the difference between the normal maps standard 
used in 3ds Max and Maya?

•	The green channel is reversed. You can select the normal 
maps standard in the menu View->Options. 

When should I use the DX version and when the GL version?

•	It depends on your hardware. 3D-Coat has two Graphics 
Modes: DX (DirectX) and GL (OpenGL). the GL mode usu-
ally runs much faster than DX mode on professional Quadro 
graphics card, while the DX mode will run faster on consumer-
level game graphics card. 

What’s the difference between “Depth” and “Sculpt mode”?

•	In 3D-Coat there are two types of sculpting modes: one is 
image-based and another is mesh-based. “Depth” is image-
based sculpting – in this mode you are drawing the depth by 
creating a vector displacement, the normal map and displace-
ment map is generated “on the fly.” If you want to get hold 
of the normal map, just save it – it’s not necessary to wait a 
long time for baking, because the normal map is generated 
in real-time. 

•	When you enter “Sculpt mode”, you enter the mesh-based 
sculpting mode. In this mode you you’re really changing 
the vertex positions of the mesh. If you want to get correct 
normal map in this mode, you may use Textures->Texture 
Baking Tool.

What’s the use of the Cavity painting?

•	Cavity painting lets you paint in the crevices of the surface 
without affecting the rest of the area, and vice versa.

I selected the command “View->Environment Shade”, but 
there seems to be no change, why?

•	You can only use “Environment Shade” if you have a specu-
larity map in the model. That means if you haven’t painted 
specularity on the model, you will not see any change. 

Why is drawing with the SHIFT key so confusing?

•	Different sequences of the SHIFT key and the lmb will result 
in different effects. If you first press and hold SHIFT and then 
draw with lmb, the surface will be smoothed. But if you first 
press and hold lmb and then press SHIFT and draw, you will 
get straight lines – just like in Photoshop.

How can I create a seamless texture using 3D-Coat?
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•	It is easy to use 3D-Coat to create seamless textures and 
bump maps. Just go to menu File->Import->Image Plane, 
you may want to use Textures->Offset tool as well. You can 
read more about it on page.

What are the best practices regarding memory management 
and increasing stability?

•	When 3D-Coat is run you can see the amount of free memory 
in the left bottom corner. If this value becomes too low (200-
300 MB), the program can become unstable. These tips will 
help you to increase stability. 

•	3D-Coat consumes much memory for highly detailed objects, 
so it is important to allow 3D-Coat to use as much virtual 
memory as possible. So, please adjust your virtual memory 
settings as shown on this picture (this is taken from 32-bit 

Windows XP, things will be simi-
lar with other OS versions). Go 
to MyComputer->Properties-
>Advanced->Performance-
>Advanced->Virtual Mem-
ory->Change. Please set this 
number to 4096KB. 3D-Coat 
supports even larger virtual 
memory ranges. If you are 

using 64-bit Windows you will be able to use up to 4GB of 
virtual memory. So, using 64-bit Windows with 3DC is the best 
choice. If you are using 32-bit Windows, you can ordinarily 
use only 2 GB of virtual memory – but you can increase that 

size using the special “/3GB” option in the file boot.ini. With 
that option you will be able to use 3GB of memory with 3DC. 

How can I find and safely edit the file “boot.ini”?

•	Right-click My Computer->Properties. The System Properties 
dialog box will appear.

•	Click the Advanced tab.

•	In the Startup and Recovery area, click Settings. The Startup 
and Recovery dialog box will appear.

•	In the System startup area, click Edit. This will start Notepad 
and open “boot.ini”.

•	In the [Operating Systems] section, add the following switches 
to the end of the startup line that includes the /fastdetect 
switch: /3GB

•	Save the changes and close Notepad.

•	Click “OK” twice to close the dialog boxes, and then restart 
the computer for the change to take effect.

You can read more about the /3GB option here:
http://technet.microsoft.com/en-us/library/bb124810.aspx
http://www.vfxpedia.com/index.php?title=FAQ/3GB_Switch
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15. Contacts & Credits
Official 3D-Coat web-site:
www.3d-coat.com

Lead Programmer: 
Andrew Shpagin
support@3d-coat.com

Web-designer/Webmaster: 
Vladimir Popelnukh
web@3d-coat.com

Sales manager: 
Stanislav Chernyshuk
sales@3d-coat.com

PR manager: 
Denis Yanev
d.yanev@3d-coat.com

Authors of the manual: 
Luo Chen, Marina Shpagina, Dwayne Ferguson, Daniel Yarmak, 
Klaus Nordby and Javis Jones

Manual design:
Klaus Nordby
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16. Printing this manual
You may of course also print this manual! But you probably don’t 
want to waste unnecessary ink. Please follow these simple instruc-
tions to remove the grey background in this PDF document.

In Adobe Reader, first move your cursor to View->Navigation 
Panels->Layers. You should then see, on the left side, a new 
panel called “Layers”. You will only see “3DC-Manual” or some-
thing similar. Then click next to the “+” icon to expand the Layer 
system. You should see a layer named “Gray background”, and 
right next to it a visibility icon, represented by an eyeball. Click 
the eyeball to toggle the visibility off. All this is clearly shown in 
the images on this page. You should now see a white background in this document, 

and can print it using much less ink.
If you want to save even more ink, you can also hide the layer 

named “Images” – and only print the text parts of this manual.
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